Error al actualizar repositorios (apt-get update)

Hasta hace poco me entere (soy nuevo en esto del soft. libre, no tengo ni 3 meses) que los sistemas GNU/Linux trabajan bajo firmas de repositorios. ¿Qué significa esto?, pues de manera sencilla aquí lo explico:

De forma breve, los repositorios que se encuentran disponibles a través de gestores como "Synaptic" cambian su firma al verse comprometidos, esto lo hacen para tener una mayor seguridad en su sistema, de forma que debemos adquirir una nueva llave o firma para no tener problemas con dichos repositorios.


¿Como se cuando esto ocurre?

Muy fácil, al editar el archivo "sources.list" para agregar mas repositorios, al hacer un actualización con "apt-get update" nos saldrá un mensaje que va mas o menos así:

W: Error de GPG: http://ppa.launchpad.net intrepid Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY XXXXXXXXXXXXXXXX
W: Tal vez quiera ejecutar ‘apt-get update’ para corregir estos problemas


Donde XXXXXXXXXXXXXXXX serán una serie de números y letras.


¿Qué hacer entonces?

Cuando aparece esto es que necesitamos una nueva llave, para conseguirla hacemos lo siguiente:

gpg --keyserver keyserver.ubuntu.com --recv XXXXXXXXXXXXXXXX


NOTA: son 2 guiones, cuidado con esto.

Si lo hemos hecho bien, entonces ya podemos hacer un update.

sudo aptitude update


Y ya no nos debería salir mas el mensaje de que la llave que tenemos no es válida y el proceso debería terminar sin ningún tipo de error.

NOTA: recuerda hacer esto por cada llave que necesites, si necesitas actualizar, por ejemplo, 3 llaves, realiza el proceso 3 veces con cada una.

Lamentablemente hay muchos usuarios en la red que han llegado al blog para escribir obscenidades, así que la moderación se hace necesaria. Recuerda utilizar un lenguaje correcto y espera a que sea aprobado.

Si necesitas publicar código haz click en "Conversión" para hacerlo legible.
ConversiónConversión EmoticonEmoticon